Emergency Unplanned Backbone WAN maintenance

Incident Report for DataBridge Sites

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 10:40 UTC

Update

We are continuing to investigate this issue.
Posted Mar 26, 2025 - 10:39 UTC

Investigating

A carrier has notified us of an Emergency Demand Maintenance Event on their Fiber network.
Posted Mar 26, 2025 - 06:03 UTC
This incident affected: MDC-CHI Backbone interconnect.